The location field in profile is kind of broken

The location field in the profile is the user profile is somewhat broken (which may be why nobody really uses it).

Every character you type updates the location search, and it very quickly decides that you’re searching for locations too often and tells you to wait to do it again (and then doesn’t suggest locations until you have waited).

I have no issue with my profile while entering an address, the autocompletion and selection work. Can you give me an example address that triggers this?

It seems you can type 6 characters before it says,
“You’ve performed this action too many times. Please wait 55 seconds before trying again.”

I for example live in Woodlesford, which is far more than 6 characters, and deletions also seem to count towards that number.

No correct suggestions come up at 6 characters.

I tried very long city names, typing characters one by one, slow or fast, and I didn’t encounter any issue :man_shrugging:

Is it possible that you capture a video/gif of that happening?

BIzarre. I’ve tried on Firefox, Firefox mobile, and Vivaldi and experienced the same on all of them.

I also disconnected from the WiFi in case it was my DNS ad-blocking that was causing an issue. It’s still doing it.

Here’s a very quick video on my phone (to keep it under 4MB)

I have no clue.

The location plugin gives access to several location providers, but I don’t know anything about this stuff. I don’t know which ones are free, which one needs an actual API key, and what are the various limitations of each provider.
By default, it uses nominatim.

image


Since you’re the first to report the issue, I’m a bit reluctant to change the setting… :man_shrugging:

Anyone here encounter the same issue?

I see the same behaviour as @mowcius

Using my phone, the same thing happened to me. Then, I waited 55 seconds and entered my zip code/postal code. It worked.

Yes I imagine it’s a setting in order to limit hammering a free API.

Or perhaps it’s the API itself reporting back that we’re making requests too fast.

It just seems like you get a very small request number before the limit - if it was doubled or tripled it’d likely make zero difference to the number of requests, but would resolve the oddities. I presume you can’t easily make a change like that though even if it is on the Discourse end.

Yeah, you can get there eventually, but I wonder whether the fact it can take numerous minutes to update the location field is one reason that not so many people have done it.

No issue on my smartphone either. I’ll ask the plugin’s author.

Same issue there, on Firefox Mobile 96.3.1.

Haha, I just noticed the issue right at the bottom of your image.

Location Geocoding Rate [limit] appears to be set to 6. That permits 6 characters (searches) per minute.

Make it more like 30 and we’ll be golden.

However, if you are using Nominatim then does this come under the following forbidden use?

Unacceptable Use

The following uses are strictly forbidden and will get you banned:

  • Auto-complete search This is not yet supported by Nominatim and you must not implement such a service on the client side using the API.

Although I guess it’s not actually doing an autocomplete?

https://operations.osmfoundation.org/policies/nominatim/

1 Like

Yes, I also have this feeling and have asked this to the Plugin’s author as well. :slight_smile:
It should ideally behave the same way as when you add a location when creating a new #trading-post topic.

Well I don’t really know how this stuff works. It looks very much like an autocomplete though. :person_shrugging:

I saw that but since I didn’t encounter the issue I was puzzled. Plus their policy states “No heavy uses (an absolute maximum of 1 request per second).” :person_shrugging:


For those interested…

I think 30 requests a minute is probably OK to do occasionally. It will average out at significantly less than 1 request per second, especially for how infrequently anyone’s going to be updating their location.

I wonder whether you don’t encounter the issue simply because you’re an admin so it ignores those limits.

Let’s tweak this. I’ve made it to 20.

Can you tell me (fully reload the website before) if it still happens to you guys?

It now permits 20 characters, which is probably more likely to be enough for most people.

1 Like

Off topic. Thank you for using Vivaldi, even if for a limited test. :wink:

1 Like