Spring 2011 - Sweet ridin'

Here is mine and my friend’s edit for his school. :slight_smile: I hope you like it… don’t forget to watch in HD and please leave a comment! :wink:

Really good filming,editing and riding! Keep it up!:slight_smile:

Thanks :slight_smile:

Very nice editing. It made the video pleasurable to watch.

That was really well done. The nice calm edit was very nice to watch.

Cool video! What camera did you use?:slight_smile:

Thanks, Im really glad you like it :slight_smile:
Its filmed with canon eos 550d.

very very nice! :smiley:

very nice edit and not bad riding! :slight_smile:

that edit was epic haha
loved it!
i want to see some more videos from you in the future :slight_smile:

I really liked the song and colors :smiley: but over use of Twixtor :frowning: Fine for a class though

such a nice video, the filming and edit were epic. and the riding was top notch too. keep up the good work :slight_smile:

This was one of the best videos i’ve seen in a while

Thank you all! :slight_smile:
I’m gonna make some more videos in near future for sure… -more about MUNI.

I really liked it. But the audio was funky for me, I don’t know what that song is supposed to sound like normally, but the highs sounded like they were clipping, especially over the vocals. Really enjoyed the riding though

Yea, I don’t know why is the sound so bad in my video, but this is how it should sound:

Ah yes, you probably just had the audio level too high in your edits. A lot of programs import songs at super high audio levels, which is weird, but it lets you select a wide range of volume. I bet if you set the volume to half of the level it was at, it would be fine.

Ok, thanks for the advice :wink: