Hard to push gearshift buttons

Hello! I’ve got troubles pushing gearshift buttons on my G36 unicycle: it takes quite much power to shift.
Spoke tension seems OK, what else should i check?

Hi! Had the same problem and solved…
Remove the shifting buttons, remove the inner screws in the buttons, check if the cranks are perfectly pushed inside tightening the two big screws.

Without the buttons does it works? If not, go on…

Remove the cranks and clean the hub with the grease (or with another lube).

Now try to shift with the hands pushing on both sides of the inner big screw, many times, allowing the grease to reach the inner part of the mechanism.

Does it works? Mine worked at this time…

Then reassemble everything and you’re ready to shift! (maybe)

I said that you must remove the small screws inside the shofting buttons, to check if they are screwed simmetrically, cause I had also this problem…

I hope I’ve been useful


OK, cleaning with grease helped a bit. Now I’ve got in to the way of shifting gears. Last ride I’ve tried my friend’s G36 and it seems that pushing force is normal (but my hub shifts harder a bit).