ASP cookie help?

Hi -

I’m trying to test out some ASP code that sets a cookie - unfortunately
I can’t get my cookies to work. The tutorials lay them out pretty
plainly so I don’t see what I could be doing wrong.

My question is - since I’m testing by running the ASP on localhost (all
the web servers I have available are linux), do you think that is the
problem? Because I’ve copied and pasted code exactly, ran test scripts
as-is, etc, and it just doesn’t seem to be working for me…?

ex:

Response.Cookies(“mycookie”) = “testcookie”
Response.Cookies(“mycookie”).Domain = “www.domain.com
Response.Cookies(“mycookie”).Secure = “False”
Response.Cookies(“mycookie”).Expires = Date + 365

This code, written out exactly in ASP is NOT setting the cookie…??

Re: ASP cookie help?

Do you have IIS installed on the local host?

Shena Delian O’Brien wrote:

> Hi -
>
> I’m trying to test out some ASP code that sets a cookie - unfortunately
> I can’t get my cookies to work. The tutorials lay them out pretty
> plainly so I don’t see what I could be doing wrong.
>
> My question is - since I’m testing by running the ASP on localhost (all
> the web servers I have available are linux), do you think that is the
> problem? Because I’ve copied and pasted code exactly, ran test scripts
> as-is, etc, and it just doesn’t seem to be working for me…?
>
> ex:
>
> Response.Cookies(“mycookie”) = “testcookie”
> Response.Cookies(“mycookie”).Domain = “www.domain.com
> Response.Cookies(“mycookie”).Secure = “False”
> Response.Cookies(“mycookie”).Expires = Date + 365
>
> This code, written out exactly in ASP is NOT setting the cookie…??

Re: ASP cookie help?

Yes. I tested it and other ASP is working fine.

Deborah wrote:
> Do you have IIS installed on the local host?
>
> Shena Delian O’Brien wrote:
>
>
>>Hi -
>>
>>I’m trying to test out some ASP code that sets a cookie - unfortunately
>>I can’t get my cookies to work. The tutorials lay them out pretty
>>plainly so I don’t see what I could be doing wrong.
>>
>>My question is - since I’m testing by running the ASP on localhost (all
>>the web servers I have available are linux), do you think that is the
>>problem? Because I’ve copied and pasted code exactly, ran test scripts
>>as-is, etc, and it just doesn’t seem to be working for me…?
>>
>>ex:
>>
>>Response.Cookies(“mycookie”) = “testcookie”
>>Response.Cookies(“mycookie”).Domain = “www.domain.com
>>Response.Cookies(“mycookie”).Secure = “False”
>>Response.Cookies(“mycookie”).Expires = Date + 365
>>
>>This code, written out exactly in ASP is NOT setting the cookie…??
>
>